FAQ - CentOS 5 von PHP 5.1 auf PHP 5.2 (nicht 5.3) upgraden

Um unter CentOS 5 (z.B. virtueller Server) von PHP 5.1 auf 5.2 (nicht 5.3) upzugraden wie folgt vorgehen

Repository von Atmic Corp in CentOS 5 einbinden mit dem Befehl

wget -q -O - http://www.atomicorp.com/installers/atomic.sh | sh

Dann unter /etc/yum.repos.d die angelegte Datei: atomic.repo anpassen um den Upgrade auf PHP 5.3 zu verhindern. z.B. mit nano /etc/yum.repos.d/atomic.repo

exclude = php*5.3*

Danach den Upgrade von PHP durchführen

yum update php

mcrypt aktualisieren wenn notwendig mit:

yum update php-mcrypt

Wenn upgrade beendet kurz prüfen, ob die neue Version von PHP installiert ist:

php -v

Um die Änderung anzuwenden muss Apache (httpd-Dienst) neu gestartet werden:

service httpd restart

Add Feedback